Tunnel IPv6 Over IPv4

Goal : R1 (IPv6 2000::1) is able to ping R5 (IPv6 4000::5) and vice versa. IPv6 Network using RIP as routing protocol and IPv4 using OSPF. No direct link between R2 & R4, using tunnel interface instead.

 

Scenario : 

- Create IPv4 & IPv6 addresses on each router as picture above

- No need to config IPv6 in R3 & there is no directly connected link between R2 & R4

- Create OSPFv2 and advertise IPv4 network address in R2, R3, R4

- Create tunnel interface mode ipv6ip (default mode is GRE) in R2 & R4, 

- Tunnel source is Lo1 for R2 & R4, and make sure tunnel destination addresss is reachable.

- All RIPng routers should reachable by each other.

- Verify : show ipv6 route, test ping / trace IPv6 address from R1 to R5 and reverse 

 

Configuration :

- OSPF Config R2,R3,R4

R2#sh run | sec router

router ospf 1

 log-adjacency-changes

 network 2.2.2.0 0.0.0.255 area 0

 network 192.168.23.0 0.0.0.255 area 0

 

R3#sh run | sec router

router ospf 1

 log-adjacency-changes

 network 192.168.23.0 0.0.0.255 area 0

 network 192.168.34.0 0.0.0.255 area 0

 

R4#sh run | sec router

router ospf 1

 log-adjacency-changes

 network 4.4.4.0 0.0.0.255 area 0

network 192.168.34.0 0.0.0.255 area 0

 

- IPv6 & RIPng R1,R2,R4,R5

R1#

ipv6 router rip RIPNG

 

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address 2000::1/64

 ipv6 rip RIPNG enable

 

R2#

ipv6 router rip RIPNG

 

interface FastEthernet0/1

 no ip address

 duplex auto

 speed auto

 ipv6 address 2000::2/64

 ipv6 rip RIPNG enable

 

interface FastEthernet1/0

 ip address 192.168.23.2 255.255.255.0

 duplex auto

 speed auto

end

 

interface Loopback1

 ip address 2.2.2.2 255.255.255.0

 ipv6 rip RIPNG enable

 

interface Tunnel0

 no ip address

 ipv6 address 3000::2/64

 ipv6 rip RIPNG enable

 tunnel source Loopback1

 tunnel destination 4.4.4.4

 tunnel mode ipv6ip

end

 

 

R4#

ipv6 router rip RIPNG

 

interface FastEthernet0/0

 no ip address

 duplex auto

 speed auto

 ipv6 address 4000::4/64

 ipv6 rip RIPNG enable

end

 

interface FastEthernet2/0

 ip address 192.168.34.4 255.255.255.0

 duplex auto

 speed auto

end

 

interface Loopback1

 ip address 4.4.4.4 255.255.255.0

 ipv6 rip RIPNG enable

end

 

interface Tunnel0

 no ip address

 ipv6 address 3000::4/64

 ipv6 rip RIPNG enable

 tunnel source Loopback1

 tunnel destination 2.2.2.2

 tunnel mode ipv6ip

end

 

R5#

ipv6 router rip RIPNG

 

interface FastEthernet0/1

 no ip address

 duplex auto

 speed auto

 ipv6 address 4000::5/64

 ipv6 rip RIPNG enable

 

end

 

Verify: